Search not returning correct results

9 months 3 days ago #3713 by bodeinvenice
Search not returning correct results was created by bodeinvenice
Hello,

Search isn't returning the correct results. Here's a sample page: oiablog.cloudaccess.host/en/locations

We have 2 offices in California. If you do a search for "California" or "CA", there are No Results. Same for "Texas" and "Oregon" where we also have offices.

Also noticed that the Zip Codes don't seem to return European countries. For example the code for the Barcelona location is 08010 but that search term only returns results in New Jersey and New York.

Thanks for your help in advance!
Nick

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago #3714 by sysgenmedia
Replied by sysgenmedia on topic Search not returning correct results
Hi Nick,

First you need a better understanding of how the search works. It takes the query and converts it to a location, or coordinates based on the terms. Then they system searches from that center point up to the radius as defined on the search form.

1. So the the issue with your CA results is that CA or California will result in searching from the geographical center of CA, up to the radius (currently defaulted to 25 miles). This wont cover it. Try a more specific search like 90703. Same as Texas, etc.

2. This is again because the system is attempting to convert that zipcode to a location. If you searched '08010, Spain" for instance it works. Luckily, google will bias the results based on the users physical location, so if a user in Spain searches for 08010 it should hopefully return Barcelona. Alternately you can specify that people include their country when searching.

Please Log in or Create an account to join the conversation.

More
9 months 2 days ago #3715 by bodeinvenice
Replied by bodeinvenice on topic Search not returning correct results
Hello.

That makes sense … thank you.

I do have one more question. On mobile or small screens, the address pop-up information is not responsive … it's wider than the device screen which makes it very difficult to read.

Thanks again!

~ Nick

Please Log in or Create an account to join the conversation.

More
9 months 1 day ago #3716 by sysgenmedia
Replied by sysgenmedia on topic Search not returning correct results
Interesting, we'll look into fixing that...

Please Log in or Create an account to join the conversation.

More
8 months 3 weeks ago #3718 by bodeinvenice
Replied by bodeinvenice on topic Search not returning correct results
Hello,

I was just circling back to see if there's any update on when this item might be resolved. We were hoping to launch in the next week but can't if the maps aren't working properly yet.

Thanks,
Nick

Please Log in or Create an account to join the conversation.

More
6 months 3 days ago #3748 by sysgenmedia
Replied by sysgenmedia on topic Search not returning correct results
This should now be fixed in our current release. Let us know if there are still any issues.

Please Log in or Create an account to join the conversation.

More