Maps error after a few seconds

2 months 6 days ago #3795 by yves.zuest@gmail.com
Maps error after a few seconds was created by yves.zuest@gmail.com
Hello

The maps is loading for a few seconds, after that there is a error. This could be a problem with the API but i don't know what exactly. The message doesn't help me: InvalidKeyMapError

Could you please have a look?

bioladentag.ch.80-74-150-110.hobo.sui-in...ex.php/store-locator

Thank you very much!
Yves

Please Log in or Create an account to join the conversation.

  • yves.zuest@gmail.com
  • Topic Author
  • Offline
More
2 months 6 days ago #3796 by sysgenmedia
Replied by sysgenmedia on topic Maps error after a few seconds
It looks like you have an invalid Google Maps API Key.

Google recently made changes to Google Maps API. It has been rebranded as Google Maps Platform.

You’ll need to now setup a billing account with Google. For 99% of users, typical usage is still free but you’ll need to have a payment method on file with Google to use Google Maps Platform.

See their Guide for Existing Users for more details: cloud.google.com/maps-platform/user-guide/

To simplify the process, you should get a new API Key & get started here: cloud.google.com/maps-platform/#get-started
— Choose Maps & Places at a minimum during setup.

We recommend not setting any restrictions on the key until you get everything working.

The Google API Key can then be set in the Store Locator's Options in Joomla.

Please Log in or Create an account to join the conversation.

More
2 months 3 days ago #3797 by yves.zuest@gmail.com
Replied by yves.zuest@gmail.com on topic Maps error after a few seconds
Hello

Thanks for the answer.

Ok i just checked and the API Should be right. The API Key is set in joomla.

These API's are activated:
Directions API, Geocoding API, Geolocation API, Maps Embed API, Maps JavaScript API, Maps Static API, Places API, Street View Static API

I also tried different Templates but it's still the same.

Kind Regards.

Please Log in or Create an account to join the conversation.

  • yves.zuest@gmail.com
  • Topic Author
  • Offline
More
2 months 2 days ago #3798 by sysgenmedia
Replied by sysgenmedia on topic Maps error after a few seconds
Looks like you got it working! Let me know if you still need help. Seems to be good both showing the map and searching now.

Please Log in or Create an account to join the conversation.

More