Trouble importing csv, getting an error message

1 year 2 months ago - 1 year 2 months ago #3687 by carramone
When I try to import a CSV file I get the following error "Error Importing Row: 1 - Incorrect number of columns. Make sure you Have 18+ Columns". I have tried to update the file putting quotes on every single entry but that doesn't work either. I have attached a file so that you can see how it looks.

I have tried to export it from excel both as comma separated CSV, and comma separated CSV (UTF-8) but regardless I get the same result.

Any idea what it is I'm doing wrong?

Store Locator: 2.5.1.0
Joomla: 3.8.8
PHP: 7.1.17-1+ubuntu16.04.1+deb.sury.org+1
Last edit: 1 year 2 months ago by carramone. Reason: typos

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #3688 by sysgenmedia
Replied by sysgenmedia on topic Trouble importing csv, getting an error message
The file didn't come through, can you email it to support @ sysgenmedia.com (without the spaces) :)

We'll take a look and see whats going on.
The following user(s) said Thank You: carramone

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #3689 by sysgenmedia
Replied by sysgenmedia on topic Trouble importing csv, getting an error message
Also, if its an option try exporting from excel as a Windows CSV file.
The following user(s) said Thank You: carramone

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #3690 by carramone
Replied by carramone on topic Trouble importing csv, getting an error message
Hi, thank you.
When I exported to Windows CSV it worked. It did however only import empty rows and it also said that there were a lot of errors. But that problem was easy to fix. The problem was the CSV export from excel that didn't work as I expected it to do. Excel added " around every cell by itself, it also used ; instead of , to seperate cells. This gave me a file that looked like this:

"""Name";"""";"""";"" ....

When I batch replaced """ with " and ; to , the file worked.

Thank you very much,
Rikard

Please Log in or Create an account to join the conversation.

More