Some postcodes/suburbs don't come up in search

7 years 7 months ago #796 by jason@thinker.com.au
Some postcodes/suburbs don't come up in search was created by jason@thinker.com.au
I have two separate maps loaded on my site, located at thinker.com.au .

The first is located under the Gigs menu: thinker.com.au/index.php/gigs

while the other loads after using the Search Module: thinker.com.au/index.php?option=com_stor...&Itemid=514&view=map

They are two separate maps generated by different menu items.

The odd thing I'm finding is that some suburb/postcode locations generate no results, even though there are marker locations either in that suburb or nearby. The issue is happening on both maps.

Searching for Kings Cross correctly locates the marker located in Kings Cross and two nearby, however searching for Newtown, Enmore, Stanmore, Petersham, 2042 generates no results. Searching for Glebe returns the marker for Glebe as well as the marker located in Newtown (so the component is recognising the Newtown location as present).

Thoughts?

Please Log in or Create an account to join the conversation.

  • jason@thinker.com.au
  • Topic Author
  • Offline
More
7 years 7 months ago #805 by sysgenmedia
Replied by sysgenmedia on topic Some postcodes/suburbs don't come up in search
Hi Jason,

Looking into your issue, i have found the cause being an ambiguity in the search phrase. In searching, the first result i get is Newtown, PA, USA, which is not near your locations hence no results are found.

You may be able to fix this issue, by setting the Base Country parameter in the component options to Australia. This would bias the results to more likely return Australian locations but does not guarantee a fix.

Hopefully that will do the trick. However, we are working on adding the ability to refine the search if more than one result is found in a future release.

Jared

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #825 by jason@thinker.com.au
Replied by jason@thinker.com.au on topic Some postcodes/suburbs don't come up in search
I already have the base country set to Australia. Thing is, it works for the other site that I have built using the Store Locator Search module (Everything Entertainment) which can be viewed at everythingentertainment.com.au/gigs-mobile.html?device=iphone . While I don't doubt I may have missed something, I'm pretty proficient with the settings of Store Locator now so I don't think I missed anything... The only difference between the two site's configs is that EE's site has directions enabled whereas Thinker's doesn't.

Please Log in or Create an account to join the conversation.

  • jason@thinker.com.au
  • Topic Author
  • Offline
More
7 years 7 months ago #826 by jason@thinker.com.au
Replied by jason@thinker.com.au on topic Some postcodes/suburbs don't come up in search
I already have the base country set to Australia. Thing is, it works for the other site that I have built using the Store Locator Search module (Everything Entertainment) which can be viewed at everythingentertainment.com.au/gigs-mobile.html?device=iphone . While I don't doubt I may have missed something, I'm pretty proficient with the settings of Store Locator now so I don't think I missed anything... The only difference between the two site's configs is that EE's site has directions enabled whereas Thinker's doesn't.

Please Log in or Create an account to join the conversation.

  • jason@thinker.com.au
  • Topic Author
  • Offline
More
7 years 7 months ago #828 by sysgenmedia
Replied by sysgenmedia on topic Some postcodes/suburbs don't come up in search
Interesting... I think this may have to do with the fact that your first site is using the older Google Maps API (v2), and the new site is using v3... This may be causing some differences in how searches are encoded...

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #829 by jason@thinker.com.au
Replied by jason@thinker.com.au on topic Some postcodes/suburbs don't come up in search
Any thoughts on how to fix it? Maybe install the older version or will there be an update to correct?

Please Log in or Create an account to join the conversation.

  • jason@thinker.com.au
  • Topic Author
  • Offline
More
7 years 7 months ago #830 by sysgenmedia
Replied by sysgenmedia on topic Some postcodes/suburbs don't come up in search
It cant be fixed per se, as its a change in Google's algorithm, however we are working on adding a refinement layer suggesting clarifications when this occurs...

Jared

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #831 by jason@thinker.com.au
Replied by jason@thinker.com.au on topic Some postcodes/suburbs don't come up in search
So that pretty much leaves me with installing an older version of the component?

Please Log in or Create an account to join the conversation.

  • jason@thinker.com.au
  • Topic Author
  • Offline
More
7 years 7 months ago #834 by sysgenmedia
Replied by sysgenmedia on topic Some postcodes/suburbs don't come up in search
unfortunately, for the time being yes... since this is a change on Google's side we are unable to compensate for it directly, but the update above should solve that issue and it will be in the next release which should be out next week sometime.

Please Log in or Create an account to join the conversation.

More