Inconsistent search functionality across browsers

2 years 6 months ago #3462 by chris@marchdigital.com.au
Inconsistent search functionality across browsers was created by chris@marchdigital.com.au
Hi,

We seem to be getting very inconsistent search functionality for the Store Locator when using different browsers, For instance, when we search on a specific town or post code in Chrome (Mac) we usually get results - but searching for the exact same location on Safari we get 'no results found'. However, Safari does return results for other locations - and oddly, it seems to work perfectly fine on some computers running the exact same version of Safari. Is there something we need to be doing in Joomla settings to ensure that it ALWAYS works on all browsers?

Our site is url is www.fennerdunlop.com.au/our-company/locations

Thanks in advance,

Chris Walker

Please Log in or Create an account to join the conversation.

  • chris@marchdigital.com.au
  • Topic Author
  • Offline
More
2 years 5 months ago #3473 by sysgenmedia
Replied by sysgenmedia on topic Inconsistent search functionality across browsers
This is a common Google API issue with Australia.

Try Setting the Country Search Bias in the Component Options.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #3491 by chris@marchdigital.com.au
Replied by chris@marchdigital.com.au on topic Inconsistent search functionality across browsers
Hi,

I have tried adding the Country Search Bias in the Component Options in both the main options and on the menu item - and it is still not working. Oddly, when I search "Sydney" I get results for location in and around the Sydney area (for instance, Revesby) - but if I then search "Revesby" I get 'no results'.

Even searching known post codes yields no results even though locations within those post codes do exist in the database.

Regards

Chris

Please Log in or Create an account to join the conversation.

  • chris@marchdigital.com.au
  • Topic Author
  • Offline
More
2 years 2 months ago #3505 by sysgenmedia
Replied by sysgenmedia on topic Inconsistent search functionality across browsers
I dont think you are using our extension, but if you wanted to try increasing the search radius.

Please Log in or Create an account to join the conversation.

More